$re = '/,(?![^{]*\})/m';
$str = '{"A": "B", "C":{"D":"E"}, "F": {"G"}, "H":"I"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);