package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a.{3,}?c)`)
var str = `dabbcbcbabce`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}