# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<NUMBER>[+-]?[0-9]+\.[0-9]+|-?\+?[\d]+)|(?P<LPAR>\()|(?P<RPAR>\))|(?P<NAME>%?\w\w*\-?>?\w*\!?\??\.? |[\+\-\.]+?)|(?P<BOOL>#t|#f|true|false)|(?P<STRING>^\"[\w].*[\w]*\")|(?P<CHAR>[#|\\a|\b|\\Backspace]+)|(?P<COMMENT>[;;].*$)|(?P<QUOTES>\'+|\"+)|(?P<OP>[\?==|<=|=|>=\-+*/<>])|(?P<IGNORE>[\s\t])"
test_str = (";; Retorna a sequência de Collatz para o número dado\n"
";; Argumento deve ser um número inteiro.\n"
"x ;; comentário\n"
":defn collatz n:\n"
" :if [n = 1] then:\n"
"'(+ 1 2)\n"
"#t\n"
"#f\n"
"true\n"
"false\n"
"\"dsfsfsf-dfjsif\"\n"
"-12.34\n"
"\"(das)\" ' '\n"
"#\n"
"#\n"
"\\a #\\Backspace\n"
" (list 1)\n"
" :elif (even? n) then:\n"
" (cons n (collatz [n quotient 2]))\n"
" :else:\n"
" (cons n (collatz [[3 * n] + 1]))\n\n\n"
";; Imprime a sequência de Collatz de 42")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.