using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^ ]*\ ){2}([^ ]*)";
string input = @"04/04/19 11:54:10 7.4 78 3.9 2.1 0.0 63 0.00 0.00 1000.0 ENE 0 km/h C mb mm --- --- 0.20 167.00 --- 23.3 41 7.2 --- 7.4 11:49 2.4 5:18 9.7 11:15 9.7 11:15 1000.6 0:12 998.3 5:31 2.16 2.16 4.8 7.2 --- 1.0 0.01 311 --- 0.00 0 0 0 0 0 0 0 0 0 0 ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}