package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\..+\.py.[0-9]+~`)
var str = `.main.py.3340702474~`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}