using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<remote>\S*) (?<host>\S*) (?<user>\S*) \[(?<time>[^\]]*)\] ""(?<method>\S+)(?: +(?<path>[^\""]*?)(?:\s+\S*)?)?"" (?<code>\S*) (?<size>\S*)(?: ""(?<referer>[^\""]*)"" ""(?<agent>[^\""]*)""(?:\s+(?<http_x_forwarded_for>\S+))?)?$";
string input = @"127.0.0.1 192.168.0.1 - [28/Feb/2013:12:00:00 +0900] ""GET / HTTP/1.1"" 200 777 ""-"" ""Opera/12.0""
127.0.0.1 192.168.0.1 - [28/Feb/2013:12:00:00 +0900] ""GET / HTTP/1.1"" 200 777 ""-"" ""Opera/12.0"" -";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}