# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img\s+(?=(?:[^>]*?\s)?class=\"[^\">]*emojione)(?:[^>]*?\s)?alt=\"([^\"]*)\"[^>]*>(?:[^<]*<\/img>)?"
test_str = ("Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.\n\n"
"<img alt=\"👨\" class=\"emojione\" title=\":man_mechanic_tone1:\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f468-1f3fb-1f527.png\"/>\n\n"
"<img class=\"emojioneemoji\" alt=\"👨🏻🔧\" title=\":man_mechanic_tone1:\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f468-1f3fb-1f527.png\"/>\n\n"
"<img class=\"emojioneemoji\" alt=\"😝\" title=\":stuck_out_tongue_closed_eyes:\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f61d.png\"/>\n\n"
"<img class=\"emojioneemoji\" alt=\"😝\" title=\":stuck_out_tongue_closed_eyes:\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f61d.png\">\n\n"
"<img class=\"emojioneemoji\" alt=\"😝\" title=\":stuck_out_tongue_closed_eyes:\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f61d.png\"></img>\n\n"
"<img alt=\"😝\" class=\"emojioneemoji\"title=\":stuck_out_tongue_closed_eyes:\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f61d.png\"></img>\n\n"
"<img alt=\"😝\" class=\"emojioneemoji\"title=\":stuck_out_tongue_closed_eyes:\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f61d.png\"/>\n\n"
"\"<p>test 123</p><p><img alt=\"😂\" class=\"emojioneemoji\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f602.png\"><br></p><p><img alt=\"👽\" class=\"emojioneemoji\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f47d.png\"><br></p><p><img alt=\"👊\" class=\"emojioneemoji\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f44a.png\"><br></p>\"\n\n"
"\"<p>test 321</p><p><img alt=\"😂\" class=\"emojioneemoji\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f602.png\"><br></p><p><img alt=\"👽\" class=\"emojioneemoji\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f47d.png\"><br></p><p><img alt=\"👊\" class=\"emojioneemoji\" src=\"https://cdn.jsdelivr.net/emojione/assets/4.0/png/32/1f44a.png\"><br></p>\"")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.