$re = '/\b@userid\b/i';
$str = '@userid';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);