$re = '/[a-zA-Z0-9](-?[a-zA-Z0-9])*(\.[a-zA-Z0-9](-?[a-zA-Z0-9])*)+/';
$str = 'my-domain.com or sub.my-domain.com
my--domain.com or my-domain.com-net or my-domain-.com or etc must return false.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);