import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=gene=)[^;]+";
final String string = "Chr1 0 100 gene49 Gnomon gene ID=gene49;Name=LOC101947233;Dbxref=GeneID:101947233;gbkey=Gene;gene=LOC444342;part=1%2F1\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}