re = /-o (.*%\(ext\)s).* (?:(?:--ffmpeg-location )?(.*))?/m
str = '-o D:/Deskttop/test//%(title)s.%(ext)s -i -f (best)[height=1080]/best --recode-video mp4 https://www.youtube.com/watch?v=MMuUFjxLQJU --no-playlist --encoding utf-8
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end