$re = '/^(?=.*[少]+)(?=.*[年]+).*/m';
$str = '撒dsg ....发放三安抚年萨芬少安抚按时开放';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);