#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Gesamtenergie.*\n.*\n*\s*\s(\d*)"
Local $sString = "<!DOCtype HTML PUBLIC "-//W3C//Dtd HTML 4.0 Transitional//EN">" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
"<meta HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ISO-8859-1">" & @CRLF & _
"<meta name="Generator" CONTENT="ChrisB">" & @CRLF & _
"<title>PV Webserver</title>" & @CRLF & _
"</head>" & @CRLF & _
"<body nof="(MB=(DefaultMasterborder, 65, 60, 150, 10), L=(HomeLayout, 700, 600))" bgcolor="#EAF7F7" text="#000000" link="#0033CC" vlink="#990099" alink="#FF0000" topmargin=0 leftmargin=0 marginwidth=0 marginheight=0>" & @CRLF & _
"<form method="post" action="">" & @CRLF & _
"<table cellspacing="0" cellpadding="0" width="770" nof="ly">" & @CRLF & _
"<tr><td height="5"></td></tr>" & @CRLF & _
"<tr><td width="190" height="55"></td>" & @CRLF & _
"<td width="400">" & @CRLF & _
" <font face="Arial,Helvetica,Geneva,Sans-serif,sans-serif" size="+3">" & @CRLF & _
" PIKO 5.5" & @CRLF & _
"<br><font size="+1"> " & @CRLF & _
" S_Power (220)" & @CRLF & _
"</font>" & @CRLF & _
"</font>" & @CRLF & _
"</td>" & @CRLF & _
"<td><img alt="Logo" height="42" width="130" src="KSE.gif"></td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"<font face="Arial,Helvetica,Geneva,Sans-serif,sans-serif">" & @CRLF & _
"<table Border="0" width="100%"><tr>" & @CRLF & _
"<td width="150"></td>" & @CRLF & _
"<td> <hr> </td>" & @CRLF & _
"</tr></table>" & @CRLF & _
"<table cellspacing="0" cellpadding="0" width="770">" & @CRLF & _
"<tr><td></td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td colspan="2">" & @CRLF & _
" <b>AC-Leistung</b></td>" & @CRLF & _
"<td> </td>" & @CRLF & _
"<td>" & @CRLF & _
" <b>Energie</b></td></tr>" & @CRLF & _
"<tr><td height="10"></td></tr>" & @CRLF & _
"" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" aktuell</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="140">  W</td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Gesamtenergie</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" 33763</td>" & @CRLF & _
"<td width="50">  kWh</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr height="2"><td></td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
"  </td>" & @CRLF & _
"<td width="70" align="right">" & @CRLF & _
"  </td>" & @CRLF & _
"<td width="140"> </td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Tagesenergie</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" 22.85</td>" & @CRLF & _
"<td width="50">  kWh</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr height="5"><td></td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Status</td>" & @CRLF & _
"<td colspan="4">" & @CRLF & _
" Aus</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr height="8"><td></td></tr>" & @CRLF & _
"<tr><td colspan="7">" & @CRLF & _
"<table align="top" width="100%"><tr>" & @CRLF & _
"<td width="182"></td>" & @CRLF & _
"<td><hr size="1"></font></td></tr>" & @CRLF & _
"<tr><td height="5"></td></tr></table>" & @CRLF & _
"</td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td colspan="2">" & @CRLF & _
" <b>PV-Generator</b></td>" & @CRLF & _
"<td width="140"> </td>" & @CRLF & _
"<td colspan="2">" & @CRLF & _
" <b>Ausgangsleistung</b></td>" & @CRLF & _
"<td width="30"> </td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr><td height="10"></td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" <u>String 1</u></td>" & @CRLF & _
"<td width="70"> </td>" & @CRLF & _
"<td width="140"> </td>" & @CRLF & _
"<td width="95">" & @CRLF & _
" <u>L1</u></td>" & @CRLF & _
"<td width="70"> </td>" & @CRLF & _
"<td width="30"> </td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Spannung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="140">  V</td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Spannung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="30">  V</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr height="2"><td></td></tr>" & @CRLF & _
"<tr valign="top" align="left">" & @CRLF & _
"<td width="190"> </td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Strom</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="140">  A</td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Leistung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="30">  W</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr height="22"><td></td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" <u>String 2</u></td>" & @CRLF & _
"<td width="70"> </td>" & @CRLF & _
"<td width="140"> </td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" <u>L2</u></td>" & @CRLF & _
"<td width="70"> </td>" & @CRLF & _
"<td width="30"> </td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Spannung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="140">  V</td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Spannung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="30">  V</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr height="2"><td></td></tr>" & @CRLF & _
"<tr valign="top" align="left">" & @CRLF & _
"<td width="190"> </td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Strom</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="140">  A</td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Leistung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="30">  W</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr height="22"><td></td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" <u>String 3</u></td>" & @CRLF & _
"<td width="70"> </td>" & @CRLF & _
"<td width="140"> </td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" <u>L3</u></td>" & @CRLF & _
"<td width="70"> </td>" & @CRLF & _
"<td width="30"> </td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td width="190"></td>" & @CRLF & _
"<td width="100">" & @CRLF & _
" Spannung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="140"> " & @CRLF & _
" V</td>" & @CRLF & _
"<td width="95">" & @CRLF & _
" Spannung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="30">  V</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"<tr height="2"><td></td></tr>" & @CRLF & _
"<tr valign="top" align="left">" & @CRLF & _
"<td width="190"> </td>" & @CRLF & _
"<td width="95">" & @CRLF & _
" Strom</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="140"> " & @CRLF & _
"A</td>" & @CRLF & _
"<td width="95">" & @CRLF & _
" Leistung</td>" & @CRLF & _
"<td width="70" align="right" bgcolor="#FFFFFF">" & @CRLF & _
" x x x </td>" & @CRLF & _
"<td width="30">  W</td>" & @CRLF & _
"<td> </td></tr>" & @CRLF & _
"" & @CRLF & _
"<tr><td height="15"></td></tr>" & @CRLF & _
"<tr><td colspan="7">" & @CRLF & _
"<table align="top" width="100%">" & @CRLF & _
"<tr><td width="182"></td>" & @CRLF & _
"<td><hr size="1"></font></td>" & @CRLF & _
"</tr><tr><td height="5"></td></tr></table>" & @CRLF & _
"</td></tr></table>" & @CRLF & _
"<table cellspacing="0" cellpadding="0" width="770">" & @CRLF & _
"<tr><td width="190"></td>" & @CRLF & _
"<td><font face="Arial,Helvetica,Geneva,Sans-serif">" & @CRLF & _
"<b>RS485 Kommunikation</b></td></tr>" & @CRLF & _
"<tr><td height="8"></td></tr>" & @CRLF & _
"<tr><td width="190"></td>" & @CRLF & _
"<td><font face="Arial,Helvetica,Geneva,Sans-serif">" & @CRLF & _
"Wechselrichter " & @CRLF & _
"<input type="Text" name="edWrNr" value="220" size="3" maxlength="3">" & @CRLF & _
"<input type="submit" value="Anzeigen/Aktualisieren">" & @CRLF & _
"</td></tr><tr><td height="10"></td></tr>" & @CRLF & _
"</table>" & @CRLF & _
"</td></tr></table></font>" & @CRLF & _
"" & @CRLF & _
"<hr>" & @CRLF & _
"<table cellspacing="0" cellpadding="0" width="770">" & @CRLF & _
"<tr><td height="5"></td></tr>" & @CRLF & _
"<tr><td width="190"></td>" & @CRLF & _
"<td width="330">" & @CRLF & _
"<font face="Arial,Helvetica,Geneva,Sans-serif,sans-serif">" & @CRLF & _
"<a href="LogDaten.dat">Historie</a>" & @CRLF & _
"     " & @CRLF & _
"<a href="Info.fhtml">Infoseite</a></font></td>" & @CRLF & _
"<td align="right">" & @CRLF & _
"<font face="Arial,Helvetica,Geneva,Sans-serif,sans-serif">" & @CRLF & _
"<a href="Solar2.fhtml">Einstellungen</a></font></td>" & @CRLF & _
"<td width="50"></td>" & @CRLF & _
"</tr></table></font>" & @CRLF & _
"</form>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")