using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<protocol>[a-z\-]+)?:?(?P<host>\/\/.*\.[^\/]+)$";
string input = @"https://example.domain
http://example.domain
//example.domain
//example.com
https://example.com:34
//example.com:23
example.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}