import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^[^1]*(?:1,1,1,1,1|1\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+1\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+1\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+1\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+[^1]\\D+1)[^1]*$)(?=^[^2]*(?:2,2,2,2|2\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+2\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+2\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+[^2]\\D+2)[^2]*$)(?=^[^3]*(?:3,3,3|3\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+3\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+[^3]\\D+3)[^3]*$)(?=^[^4]*(?:4,4,4|4\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+4\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+[^4]\\D+4)[^4]*$)(?=^[^5]*(?:5,5|5\\D+[^5]\\D+[^5]\\D+[^5]\\D+[^5]\\D+[^5]\\D+[^5]\\D+[^5]\\D+[^5]\\D+[^5]\\D+5)[^5]*$)^\\[\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\],\\[[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5],[0-5]\\]]$";
final String string = "[[0,1,1,1,1,1,0,0,0,0],[0,0,0,0,0,0,0,2,0,0],[0,0,0,0,0,0,0,2,0,0],[0,0,0,0,0,0,0,2,0,0],[0,3,3,3,0,0,0,2,0,0],[0,0,0,0,0,0,0,0,0,0],[0,0,0,0,0,0,0,0,0,0],[0,0,5,0,0,0,4,4,4,0],[0,0,5,0,0,0,0,0,0,0],[0,0,0,0,0,0,0,0,0,0]]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}