$re = '/(https:\/\/shop\.domein\.nl\/checkout\/[^\/]+){{.+}}\/([^\/]+){{.+}}/m';
$str = 'https://shop.domein.nl/checkout/first-part-to-capture-{{variabel-data}}/2ndpart-to-capture{{?variabel-data}}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);