$re = '~<div(?:[^<]+|(?!</?div).|(?R))*+</div>\s*~m';
$str = '<p>text</p>
<div class="bad">dsfdag</div>
<p>TEXT</p>
<div class="entry">
<div class="uptl">
<ul>
<li>1</li>
<li>2</li>
<li>3</li>
<li>4</li>
</ul>
<p>test</p>
<a href="#">link</a>
<p>test</p>
</div>
<p>test1</p>
</div>
<p>test3</p>
<p>test4</p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;