$re = '/^([A-Za-z ]*)\1*,(?:\s)(\w*,\s)(CEP\s\d{5}-\d{3})/m';
$str = 'Travessa dos Santos, 101, CEP 12345-678
Avenida Brasil, 456A, CEP 16945-017
Rua das Flores, 123, CEP 60321-105
Rua dos Sonhos Gabriel dos santos sao paulo, 12B, CEP 12345678';
$subst = "^([A-Za-zÀ-ÿ\d]+)(?:\s)([A-Za-zÀ-ÿ\d\s]+),(?:\s)(\d+[A-Za-z]?), (CEP\s\d{5}-\d{3})";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;