use strict;
my $str = 'Ole Michelsen
Web Development and Computer Science
HomeBlog
things i say
Portfolio
things i do
Tools
things i build
Profile
things about me
Photos
things i see
Feed
latest things
<head id="ctl00_Head1">
<!-- Global site tag (gtag.js) - Google Analytics -->
<script type="text/javascript" async="" src="https://www.google-analytics.com/analytics.js"></script><script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-137805785-3"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag() { dataLayer.push(arguments); }
gtag(\'js\', new Date());
gtag(\'config\', \'UA-137805785-3\');
</script>
<title>
Shillelagh - Spells - Archives of Nethys: Pathfinder 2nd Edition Database
</title><link href="Styles/layout2.css" rel="stylesheet" type="text/css"><link href="Styles/typography.css" rel="stylesheet" type="text/css"><link href="https://fonts.googleapis.com/css?family=Julee" rel="stylesheet" type="text/css"><link href="http://fonts.googleapis.com/css?family=Julee" rel="stylesheet" type="text/css"><link rel="search" type="application/opensearchdescription+xml" title="Search the Archives of Nethys" href="https://2e.aonprd.com/opensearch.xml">
<script src="./Scripts/hidefilter.js" charset="utf-8"></script>
<script src="./Scripts/toggle.js" charset="utf-8"></script>
<meta name="keywords" content="Archives, Nethys, Wiki, Archives of Nethys, Pathfinder, Official, AoN, AoNPRD, PRD, PFSRD, 2E, 2nd Edition, Spells, Shillelagh">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<style>
.nav-parent > * {
display: block;
}
.mobile-menu-toggle{
display:none;
}
#main-menu .nav-parent > .brand > .title{
display: none;
}
</style>
</head>
<body class="light">
<div id="wrapper" class="clearfix">
<form name="aspnetForm" method="post" action="Spells.aspx?ID=282" id="aspnetForm">
<div>
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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">
</div>
<div>
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="D40B405D">
</div>
<div class="page clearfix" id="page">
<div class="header">
<div class="clear hideSkiplink old" id="main-menu">
<a class="mobile-menu-toggle" id="mobile-menu-toggle" href="javascript:void(0);" data-toggle="mobile">|||</a>
<div class="splash"></div>
<div class="nav-parent" id="nav-parent">
<a href="/Default.aspx" style="font-size:larger" class="brand">
<span class="home">
Home
</span>
</a>
<a href="/Actions.aspx">Actions/Activities</a>
<a href="/Ancestries.aspx">Ancestries</a>
<a href="/Archetypes.aspx">Archetypes</a>
<a href="/Backgrounds.aspx">Backgrounds</a>
<a href="/Classes.aspx">Classes</a>
<a href="/Conditions.aspx">Conditions</a>
<a href="/Equipment.aspx">Equipment</a>
<a href="/Feats.aspx">Feats</a>
<a href="/Hazards.aspx">Hazards</a>
<a href="/Monsters.aspx">Monsters</a>
<a href="/Rules.aspx">Rules</a>
<a href="/Setting.aspx">Setting</a>
<a href="/Skills.aspx">Skills</a>
<a href="/Spells.aspx">Spells/Rituals</a>
<a href="/Traits.aspx">Traits</a>
<img src="Images/heading_flourish.png" alt="flourish" class="flourish">
<a href="/Licenses.aspx">Licenses</a>
<a href="/Sources.aspx">Sources</a>
<img src="Images/heading_flourish.png" alt="flourish" class="flourish">
<a href="/ContactUs.aspx">Contact Us</a>
<a href="/Contributors.aspx">Contributors</a>
<a href="/Support.aspx">Support the Archives</a>
<div class="search">
<input type="text" class="search-input" placeholder="Search">
<button type="button" class="search-button">
<svg class="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" style="height: 24px; width: 24px; fill: "><path d="M0 0h512v512H0z" fill="transparent" fill-opacity="0"></path><g class="" transform="translate(0,0)" style="touch-action: none;"><path d="M333.78 20.188c-39.97 0-79.96 15.212-110.405 45.656-58.667 58.667-60.796 152.72-6.406 213.97l-15.782 15.748 13.25 13.25 15.75-15.78c61.248 54.39 155.3 52.26 213.968-6.407 60.887-60.886 60.888-159.894 0-220.78C413.713 35.4 373.753 20.187 333.78 20.187zm0 18.562c35.15 0 70.285 13.44 97.158 40.313 53.745 53.745 53.744 140.6 0 194.343-51.526 51.526-133.46 53.643-187.5 6.375l.218-.217c-2.35-2.05-4.668-4.17-6.906-6.407-2.207-2.206-4.288-4.496-6.313-6.812l-.218.22c-47.27-54.04-45.152-135.976 6.374-187.502C263.467 52.19 298.63 38.75 333.78 38.75zm0 18.813c-30.31 0-60.63 11.6-83.81 34.78-46.362 46.362-46.362 121.234 0 167.594 10.14 10.142 21.632 18.077 33.905 23.782-24.91-19.087-40.97-49.133-40.97-82.94 0-15.323 3.292-29.888 9.22-43-4.165 20.485.44 40.88 14.47 54.907 24.583 24.585 68.744 20.318 98.624-9.562 29.88-29.88 34.146-74.04 9.56-98.625-2.375-2.376-4.943-4.473-7.655-6.313 45.13 8.648 79.954 46.345 84.25 92.876 4.44-35.07-6.82-71.726-33.813-98.72-23.18-23.18-53.47-34.78-83.78-34.78zM176.907 297.688L42.094 432.5l34.562 34.563L211.47 332.25l-34.564-34.563zM40 456.813L24 472.78 37.22 486l15.968-16L40 456.812z" fill-opacity="1"></path></g></svg>
</button>
</div>
<a id="minMaxMenu" href="javascript:void(0);">Minimize Menu</a>
</div>
<div class="nav-parent expand-collapse" id="mobile-nav-parent" data-target="mobile">
<a href="/Default.aspx" style="font-size:larger" class="brand">
<span class="title">
Archives of Nethys
</span>
</a>
<a href="javascript:void(0);" data-toggle="cc">Character Creation +</a>
<div class="expand-collapse expand-collapse-group hide-when-collapsed expanded" data-target="cc" data-group="menus">
<a href="/Ancestries.aspx">Ancestries</a>
<a href="/Archetypes.aspx">Archetypes</a>
<a href="/Backgrounds.aspx">Backgrounds</a>
<a href="/Classes.aspx">Classes</a>
<a href="/Feats.aspx">Feats</a>
<a href="/Skills.aspx">Skills</a>
</div>
<a href="/Equipment.aspx">Equipment</a>
<a href="/Spells.aspx">Spells/Rituals</a>
<a href="/Setting.aspx">Setting</a>
<a href="javascript:void(0);" data-toggle="rules">Rules +</a>
<div class="expand-collapse expand-collapse-group hide-when-collapsed" data-target="rules" data-group="menus">
<a href="/Actions.aspx">Actions/Activities</a>
<a href="/Conditions.aspx">Conditions</a>
<a href="/Rules.aspx">Rules</a>
<a href="/Traits.aspx">Traits</a>
</div>
<a href="/Hazards.aspx">Hazards</a>
<a href="/Monsters.aspx">Monsters</a>
<a href="/Sources.aspx">Sources</a>
<a href="javascript:void(0);" data-toggle="about" data-group="">About the Archives +</a>
<div class="expand-collapse expand-collapse-group hide-when-collapsed" data-target="about" data-group="menus">
<a href="/Licenses.aspx">Licenses</a>
<a href="/ContactUs.aspx">Contact Us</a>
<a href="/Contributors.aspx">Contributors</a>
<a href="/Support.aspx">Support the Archives</a>
</div>
<div class="search">
<input type="text" class="search-input" placeholder="Search">
<button type="button" class="search-button">
<svg class="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" style="height: 24px; width: 24px; fill: "><path d="M0 0h512v512H0z" fill="transparent" fill-opacity="0"></path><g class="" transform="translate(0,0)" style="touch-action: none;"><path d="M333.78 20.188c-39.97 0-79.96 15.212-110.405 45.656-58.667 58.667-60.796 152.72-6.406 213.97l-15.782 15.748 13.25 13.25 15.75-15.78c61.248 54.39 155.3 52.26 213.968-6.407 60.887-60.886 60.888-159.894 0-220.78C413.713 35.4 373.753 20.187 333.78 20.187zm0 18.562c35.15 0 70.285 13.44 97.158 40.313 53.745 53.745 53.744 140.6 0 194.343-51.526 51.526-133.46 53.643-187.5 6.375l.218-.217c-2.35-2.05-4.668-4.17-6.906-6.407-2.207-2.206-4.288-4.496-6.313-6.812l-.218.22c-47.27-54.04-45.152-135.976 6.374-187.502C263.467 52.19 298.63 38.75 333.78 38.75zm0 18.813c-30.31 0-60.63 11.6-83.81 34.78-46.362 46.362-46.362 121.234 0 167.594 10.14 10.142 21.632 18.077 33.905 23.782-24.91-19.087-40.97-49.133-40.97-82.94 0-15.323 3.292-29.888 9.22-43-4.165 20.485.44 40.88 14.47 54.907 24.583 24.585 68.744 20.318 98.624-9.562 29.88-29.88 34.146-74.04 9.56-98.625-2.375-2.376-4.943-4.473-7.655-6.313 45.13 8.648 79.954 46.345 84.25 92.876 4.44-35.07-6.82-71.726-33.813-98.72-23.18-23.18-53.47-34.78-83.78-34.78zM176.907 297.688L42.094 432.5l34.562 34.563L211.47 332.25l-34.564-34.563zM40 456.813L24 472.78 37.22 486l15.968-16L40 456.812z" fill-opacity="1"></path></g></svg>
</button>
</div>
<div class="edition-toggle">
<a href="https://www.aonprd.com">
Pathfinder 1<sup>st</sup> ed.
</a>
<a href="https://2e.aonprd.com" class="active">
Pathfinder 2<sup>nd</sup> ed.
</a>
</div>
<a href="https://www.aonsrd.com">Starfinder</a>
</div>
</div>
<div class="theme-toggle-wrapper" title="Toggle Theme">
<input type="checkbox" id="theme-toggle" name="theme-toggle" class="switch">
<label for="theme-toggle" id="theme-toggle-label"> </label>
<div class="tooltip">Toggle Theme</div>
</div>
</div>
<div class="main-wrapper old" id="main-wrapper">
<div class="menutitle">
<h1>
Archives of Nethys
</h1>
<h2>
<a href="https://www.aonprd.com">Pathfinder 1E</a> | <b><a href="https://2e.aonprd.com">Pathfinder 2E</a></b> | <a href="https://www.aonsrd.com">Starfinder</a>
</h2>
</div>
<div class="main" id="main">
<span id="ctl00_MainContent_Navigation"><h1 style="text-align:center"><a href="Spells.aspx?Tradition=0">All Spells</a><br><a href="Spells.aspx?Tradition=1">Arcane</a> | <a href="Spells.aspx?Tradition=2">Divine</a> | <a href="Spells.aspx?Tradition=3">Occult</a> | <a href="Spells.aspx?Tradition=4">Primal</a><br><a href="Spells.aspx?Focus=true&Tradition=0">Focus Spells</a> | <a href="Rituals.aspx">Rituals</a></h1></span>
<span id="ctl00_MainContent_SubNavigation"></span>
<hr>
<span id="ctl00_MainContent_Header"></span>
<span id="ctl00_MainContent_HeaderDescrip"></span>
<span id="ctl00_MainContent_DetailedOutput"><h1 class="title"><img src="images\\PathfinderSocietySymbol.gif" title="PFS Legal" style="margin:3px 3px 0px 3px;"> Shillelagh<span style="float:right;">Spell 1</span></h1><span alt="Plant Trait" class="trait" title="Vegetable creatures have the plant trait. They are distinct from normal plants. Magical effects with this trait manipulate or conjure plants or plant matter in some way. Those that manipulate plants have no effect in an area with no plants."><a href="Traits.aspx?ID=125">Plant</a></span><span alt="Transmutation Trait" class="trait" title="Effects and magic items with this trait are associated with the transmutation school of magic, typically changing something’s form."><a href="Traits.aspx?ID=157">Transmutation</a></span><br><b>Source</b> <a href="https://paizo.com/products/btq01y0k?Pathfinder-Core-Rulebook" target="_blank" class="external-link"><i>Core Rulebook pg. 369</i></a><br><b>Traditions</b> <a href="Spells.aspx?Tradition=4">primal</a><br><b>Cast</b> <img class="actiondark" alt="Two Actions" style="height:15px; padding:0px 2px 0px 2px" src="Images\\Actions\\TwoActions.png"><img class="actionlight" alt="Two Actions" style="height:15px; padding:0px 2px 0px 2px" src="Images\\Actions\\TwoActions_I.png"> somatic, verbal<br><b>Range</b> touch; <b>Targets</b> 1 non-magical club or staff you hold<br><b>Duration</b> 1 minute<hr>The target grows vines and leaves, brimming with primal energy. The target becomes a <i>+1 striking weapon</i> while in your hands, gaining a +1 item bonus to attack rolls and increasing the number of weapon damage dice to two. Additionally, as long as you are on your home plane, attacks you make with the target against aberrations, extraplanar creatures, and undead increase the number of weapon damage dice to three.</span>
</div>
<div class="clear">
</div>
</div>
</div>
<div class="footer" id="footer">
<div id="et-al">
<a href="mailto:nethys@archivesofnethys.com">Site Owner: Rose Winds LLC (Blake Davis)</a><a href="http://mxguarddog.com">Email Spam Checker: MX Guarddog</a>
<div id="footer-social"><a href="http://www.facebook.com/pages/Nethys-the-God-King-of-Magic/109485322401363?ref=nf" target="_blank"><img src="Images/facebook.png" width="10" height="21"></a></div>
</div>
<div style="text-align:center"><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Main Archives Page -->
<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-4953734518316037" data-ad-slot="7738185508"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</form>
</div>
<script>
initiateToggle(document.getElementById(\'theme-toggle\'));
initializeMenuToggle(document.getElementById(\'minMaxMenu\'));
var initializeSearch = function (search) {
var button;
var text;
if (search.firstElementChild.classList.contains(\'search-input\'))
text = search.firstElementChild;
if (search.lastElementChild.classList.contains(\'search-input\'))
text = search.lastElementChild;
if (search.firstElementChild.classList.contains(\'search-button\'))
button = search.firstElementChild;
if (search.lastElementChild.classList.contains(\'search-button\'))
button = search.lastElementChild;
if (search) {
search.addEventListener(\'keypress\', function (e) {
if (e.keyCode == 13) {
e.preventDefault();
if (text.value != null && text.value.length > 0)
window.location = window.location.origin + "/Search.aspx?query=" + text.value;
}
})
}
if (button) {
button.addEventListener(\'click\', function (e) {
window.location = window.location.origin + "/Search.aspx?query=" + text.value;
});
}
};
var initializeExpand = function (toggle) {
var targetAttrString = "[data-target=\'" + toggle.dataset.toggle + "\']";
//target = menu to be collapsed
var target = document.querySelector(targetAttrString);
toggle.addEventListener(\'click\', function () {
var expanded = target.classList.contains(\'expanded\');
expanded = !expanded;
if (expanded) {
//hide other in group if exists
if (target.dataset.group) {
var otherExpanded = document.querySelector(\'.expanded[data-group="\' + target.dataset.group + \'"]\');
if (otherExpanded) {
otherExpanded.classList.remove(\'expanded\');
}
}
target.classList.add(\'expanded\');
} else {
target.classList.remove(\'expanded\');
}
});
};
(function () {
//toggles = link that expands/collapses target
var toggles = document.querySelectorAll(\'[data-toggle]\');
toggles.forEach(function (toggle) {
initializeExpand(toggle);
});
//searches
var searches = document.querySelectorAll(\'.search\');
searches.forEach(function (search) {
initializeSearch(search);
});
})();
</script>
</body>
Created by Ole Michelsen updated May 13, 2018Home › Viewsource › Ole Michelsen';
my $regex = qr/<a href="Traits.*?">(\w+)<\/a>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}