re = /^[23]\d{2}(0[1-9]|1[0-2])(0[1-9]|1[0-9]|2[0-9]|3[01])(0[1-4]|1[1-9]|2[1-8]|3[1-6]|88)\d{5}/m
str = '31211193300277
31302193300418
31213173300254
31303263300557
31319033301376
31312023000576
31212043300372
31305274500051
31211193600277
29910253300372'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end