package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Z(?:[^I]U|.[^U]).*$`)
var str = `ZISADR
ZIUSADR
ZDDDDR
ZISADR
ZAUSDR
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}