$re = '/\bDOB ((?:(?:3[01]|[12][0-9]|0?[1-9]) [A-Za-z]+ )?\d{4})\b/';
$str = 'DOB 23 Jun 1959; alt. DOB 23 Jun 1958
DOB 1959; alt. DOB 1958';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);