using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"fix-str-\K\d+";
string input = @"fix-str-123456789-yet-another-str fix-str-234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}