re = /(mailto:[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+$)|(((?:https?)|(?:ftp)):\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]+\.[^\s]{2,}|www\.[a-zA-Z0-9]+\.[^\s]{2,})/m
str = 'http://www.mail.com
https://google.com
ftp://protocol.com
mailto:s.klinov@mail.ru
mailto:s-klinov@mail.ru
mailto:sklinov@mail-com.ru
mailto:s_klinov@mail.ru
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end