using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"p[a-zA-Z]*p";
string input = @"apple
banana
pear
pineapple
papaya";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}