$re = '/"key2(.*?)(?=,|}|$)/m';
$str = '{"data":{"key1":"abc","key2":"xyz"}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);