$re = '/\[(.+?)\]/i';
$str = 'My long text [HH123] 123 My long text';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);