re = /^(?<first>[^\t]+)\t(?<second>[^\t]+)(\t|\t")(?<message>(.*))("\t|\t)\d{8}\t/m
str = 'ABCDEFG 11/21/16 11:14 PM The request channel timed out while waiting for a reply after 00:00:17.9375000. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a long 27332747 HOST12345 5 Function1 12345678901234567890123456
ABCDEFG 11/21/16 11:13 PM The request channel timed out while waiting for a reply after 00:00:18. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeo 16964220 HOST23456 5 Function2 23456789012345678901234567
ABCDEFG 11/21/16 5:19 PM " " 12345678 HOST23456 5 Function2 23456789012345678901234567
ABCDEFG 11/21/16 5:19 PM " " 12345678 HOST23456 5 Function2 23456789012345678901234567
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end