$re = '/TOTAL(?:\s*(\d+(?:,\d+)?)){2}/m';
$str = 'TOTAL 600,00 571,43 28,57';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);