$re = '/\d{4,}/m';
$str = '100
999
1000
1001
15000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);