# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^# .*⤵(?:\n(?!# ).*)*)\n(^## .*)\n(?!#+ )(.*(?:\n(?!^# |## ).*)*)"
test_str = ("# Heading 1 ⤵\n"
"## Heading 1.1\n"
"Text of Heading 1.1\n"
"Text can span over multiple lines\n"
"### Heading 1.1.1\n"
"Text of Heading 1.1.1\n"
"## Heading 1.2 \n"
"Text of Heading 1.2\n"
"# Heading 2\n"
"## Heading 2.1\n"
"Text of Heading 2.1\n"
"## Heading 2.2\n"
"Text of Heading 2.2\n"
"# Heading 3 ⤵\n"
"## Heading 3.1\n"
"Text of Heading 3.1\n"
"## Heading 3.2\n"
"Text of Heading 3.2\n"
"# Heading 4")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.