package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|(?:youtube(?:-nocookie)?\.com/(?:[^/]+/.+/|(?:v|e(?:mbed)?)/|.*[?&]v=)|youtu\.be/)([^"&?/ ]{11})|vimeo\.com/(?:[a-z]+/)*([0-9]{6,11}))`)
var str = `https://vimeo.com/341989332 or https://www.youtube.com/watch?v=eUMbH6X_Adc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}