import re
regex = re.compile(r"^(\%.*|Command rejected.*)", flags=re.MULTILINE)
test_str = ("**State Acronym: H - Healthy, W - Warning, C - Critical\n"
"Resource Usage Max Warning Critical State\n"
"----------------------------------------------------------------------------------------------------\n"
"RP0 (ok, active) H\n"
" Control Processor 29.42% 100% 80% 90% H\n"
" DRAM 2840MB(72%) 3938MB 88% 93% H\n"
" bootflash 1889MB(69%) 2753MB 70% 90% H\n"
"ESP0(ok, active) H\n"
" QFP H\n"
" DRAM 81237KB(41%) 196608KB 85% 95% H\n"
" IRAM 207KB(10%) 2048KB 85% 95% H\n"
" CPU Utilization 2.00% 100% 90% 95% H\n\n"
"Load Average\n"
" Slot Status 1-Min 5-Min 15-Min\n"
" RP0 Healthy 1.24 1.20 1.23\n\n"
"Memory (kB)\n"
" Slot Status Total Used (Pct) Free (Pct) Committed (Pct)\n"
" RP0 Healthy 4033104 2909060 (72%) 1124044 (28%) 3749844 (93%)\n\n"
"CPU Utilization\n"
" Slot CPU User System Nice Idle IRQ SIRQ IOwait\n"
" RP0 0 3.51 4.89 0.00 90.10 0.95 0.53 0.00\n"
" 1 2.96 4.55 0.00 90.98 1.06 0.42 0.00\n"
" 2 21.93 2.01 0.00 75.28 0.67 0.09 0.00\n"
" 3 29.17 34.41 0.00 25.93 10.09 0.37 0.00\n\n\n\n\n\n"
" 2222233333111111111111111111111111111111 111112222222222\n"
" 100\n"
" 90\n"
" 80\n"
" 70\n"
" 60\n"
" 50\n"
" 40\n"
" 30\n"
" 20\n"
" 10\n"
" 0....5....1....1....2....2....3....3....4....4....5....5....6\n"
" 0 5 0 5 0 5 0 5 0 5 0\n"
" CPU% per second (last 60 seconds)\n\n\n\n\n"
" 1 1 1 1 1 1 1\n"
" 439546515464943339403403334255420343303354853430442395424873\n"
" 100\n"
" 90\n"
" 80\n"
" 70\n"
" 60\n"
" 50\n"
" 40\n"
" 30\n"
" 20\n"
" 10 ** **#* * # * * * *** * * * ** * ** *\n"
" 0....5....1....1....2....2....3....3....4....4....5....5....6\n"
" 0 5 0 5 0 5 0 5 0 5 0\n"
" CPU% per minute (last 60 minutes)\n"
" * = maximum CPU% # = average CPU%\n"
"% Ambiguous command\n"
"% Invalid input detected at '^' marker\n"
"% Bad Mask /xx for address X.X.X.X\n"
"% X.X.X.X overlaps with GigabitEthernet0/1\n"
"Command rejected: Conflict between 'nonegotiate' and 'dynamic' status\n"
"% Configuration of multiple subinterfaces of the same main interface with the same VID is not permitted\n"
"% Configuring IP routing on a LAN subinterface is only allowed if that subinterface is already configured as part of a VLAN\n"
"% Inconsistent address and mask\n"
"% Invalid next hop address (it's this router)\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")