re = /(?i-mx:[a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+@[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?!json|html|xml)(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)*)|(?i-mx:[a-z0-9\-]*)/
str = '.!#$%&\'*+-/=?^_` {|}~@oncologie.international'
# Print the match result
str.match(re) do |match|
puts match.to_s
end