$re = '/(?=.*[A-Z])(?=.*[0-9])[a-zA-Z0-9\.\s]{6,20}$/';
$str = 'A1CDEe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);