$re = '/(?:\G(?!^)|STUFF)\s+\K[a-z0-9(),]{1,16}(?=.*?end)/im';
$str = 'THINGS H X F N AB end STUFF H X4 O 9D I,8U JK(S) XD LMJIK END OTHER_STUFF .AS VFD F123 SDF1 SDF4... end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);