re = /(?:\G(?!^)|STUFF)\s+\K(?:(?!end)[a-z0-9(),]){1,16}(?=.*?end)/im
str = 'THINGS H X F N AB end STUFF H X4 O 9D I,8U JK(S) XD LMJIK END OTHER_STUFF .AS VFD F123 SDF1 SDF4... end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end