package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https|http):(?<url>\/\/\w+\/\w+\/)`)
var str = `https://xxxx/yyyy/test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}