re = /^(?<url1>(https|http):\/\/\w+\/\w+)(?<url2>\/[^ ]+)/m
str = 'https://xxxx/yyyy/test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end