import re
regex = re.compile(r"^(?=.+)(?:[1-9]\d*|0)?(?:\.\d+)?$", flags=re.MULTILINE)
test_str = ("123456\n"
"123.\n"
".\n"
".123\n"
"123.154574\n"
".545.4584\n"
"+1454\n"
"+487.54587\n"
"-54587.7487\n"
".1225-\n"
".456+\n"
"454.4+\n"
"454.455874\n"
"45.45745687687.5678")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")