# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"caller\"\s*:\s*\{\s*\"id\":\s*\"(?<callerid>[^\"]+)?\"\,\s*\"version\"\s*:\s*\"(?<callerversion>[^\"]+)?\""
test_str = ("{\n"
" \"info\":{\n"
" \"eventSource\":\"\",\n"
" \"sourceType\":\"I/O\",\n"
" \"status\":{\n"
" \"code\":\"\",\n"
" \"msg\":\"\",\n"
" \"msgError\":\"\"\n"
" },\n"
" \"transactionId\":null,\n"
" \"traceId\":null,\n"
" \"timestampStart\":\"2019-05-16T21:30:55.174Z\",\n"
" \"timestampEnd\":\"2019-05-16T21:30:55.174Z\",\n"
" \"companyIDCode\":\"\",\n"
" \"channelIDCode\":\"\",\n"
" \"branchCode\":\"\",\n"
" \"searchFields\":{\n"
" \"key_3\":\"value\",\n"
" \"key_2\":\"value\",\n"
" \"key_1\":\"value\"\n"
" },\n"
" \"annotation\":{},\n"
" \"caller\":{\n"
" \"id\":\"caller_01\",\n"
" \"version\":\"1.2.3\",\n"
" \"acronym\":\"\"\n"
" },\n"
" \"called\":{\n"
" \"id\":\"called_id\",\n"
" \"version\":\"3.2.1\",\n"
" \"acronym\":\"\"\n"
" },\n"
" \"storage\":{\n"
" \"id\":\"\",\n"
" \"start\":\"\",\n"
" \"end\":\"\"\n"
" }\n"
" }\n"
" },\n"
" \"headers\":[],\n"
" \"payLoad\":{\n"
" \"input\":{\n"
" \"encoding\":\"1024\",\n"
" \"ccsid\":\"1024\",\n"
" \"data\":\"dati_in\"\n"
" },\n"
" \"output\":{\n"
" \"encoding\":\"1024\",\n"
" \"ccsid\":\"1024\",\n"
" \"data\":\"dati_out\"\n"
" }\n"
" }\n"
" }\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.