#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(TITLE-.+?-[0-9]{2}-[0-9]{2})[^\s,] (.*(?:\r?\n(?![A-Z]).*)*)(?:\r?\n(?!Opening).*)*\r?\nOpening date (\d+ .*)(?:\r?\n(?!Deadline).*)*\r?\nDeadline (\d+ .*)(?:\r?\n(?!Indicative budget:).*)*\r?\nIndicative budget: .*?(EUR \d+(?:\.\d+)? \w+)"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam id diam posuere, eleifend diam at, condimentum justo. Pellentesque mollis a diam id consequat." & @CRLF & _
"" & @CRLF & _
"TITLE-SDFSD-DFDS-SFDS-01-01: This is the title 1 that" & @CRLF & _
"" & @CRLF & _
"is split into two lines with a blank line in the middle" & @CRLF & _
"" & @CRLF & _
"Conditions Pellentesque blandit scelerisque pellentesque. Sed nec quam purus. Quisque nec tellus sed neque accumsan lacinia sit amet sit amet tellus. Etiam venenatis nibh vel pellentesque elementum. Nullam eget tortor quam. Morbi sed leo et arcu aliquet luctus." & @CRLF & _
"" & @CRLF & _
"Opening date 15 Apr 2021" & @CRLF & _
"" & @CRLF & _
"Deadline 26 Aug 2021" & @CRLF & _
"" & @CRLF & _
"Indicative budget: The total indicative budget for the topic is EUR 20.00 million." & @CRLF & _
"" & @CRLF & _
"TITLE-SDFSD-DFDS-SFDS-01-02; This is the title2 in one single line" & @CRLF & _
"" & @CRLF & _
"Conditions Cras egestas consectetur sapien at dignissim. Maecenas commodo purus nibh, a tempus augue vestibulum feugiat. Vestibulum dolor neque, sagittis ut tortor et, lobortis faucibus quam." & @CRLF & _
"" & @CRLF & _
"Opening date 15 March 2021" & @CRLF & _
"" & @CRLF & _
"Deadline 17 Aug 2021" & @CRLF & _
"" & @CRLF & _
"Indicative budget: The total indicative budget for the topic is EUR 15.00 million." & @CRLF & _
"" & @CRLF & _
"TITLE-SDFSD-DFDS-SFDS-01-03: This is the title3 that is too long and takes two lines" & @CRLF & _
"" & @CRLF & _
"Conditions Cras egestas consectetur sapien at dignissim. Maecenas commodo purus nibh, a tempus augue vestibulum feugiat. Vestibulum dolor neque, sagittis ut tortor et, lobortis faucibus quam." & @CRLF & _
"" & @CRLF & _
"Opening date 15 May 2021" & @CRLF & _
"" & @CRLF & _
"Deadline 26 Sep 2021" & @CRLF & _
"" & @CRLF & _
"Indicative budget: The total indicative budget for the topic is EUR 5.00 million."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")