$re = '/\d+(?:\.\d+)?(?=\s*G)/m';
$str = '1.1G;1.2 G;1.435 G;1.1 G;1.5555G';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);