re = /data\-event\-title\=\"(.+?) vs.*?\"[^\0]*class\=\"odds\".*\>(.+?)\</
str = 'data-event-title="Yuichi Sugita* vs Adrian Mannarino">
<span class="odds-container">
<b class="odds">1/12</b>
</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end