#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?):(\d+):(\d*):?\s+(?:fatal\s+)?(warning|error):\s+(.*)$"
Local $sString = "[ 38%] Built target embedded_epjson_source" & @CRLF & _
"[ 38%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/IGUEN673.cpp.o" & @CRLF & _
"[ 38%] Building CXX object third_party/libtk205/src/CMakeFiles/libtk205.dir/rs0002_factory.cpp.o" & @CRLF & _
"[ 38%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/IGUGapDeflection.cpp.o" & @CRLF & _
"[ 38%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/IGUGapLayer.cpp.o" & @CRLF & _
"[ 38%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/IGUSolidDeflection.cpp.o" & @CRLF & _
"In file included from /usr/include/c++/13/bits/hashtable_policy.h:36," & @CRLF & _
" from /usr/include/c++/13/bits/hashtable.h:35," & @CRLF & _
" from /usr/include/c++/13/bits/unordered_map.h:33," & @CRLF & _
" from /usr/include/c++/13/unordered_map:41," & @CRLF & _
" from /home/runner/work/EnergyPlus/EnergyPlus/src/EnergyPlus/AirflowNetwork/include/AirflowNetwork/Solver.hpp:55," & @CRLF & _
" from /home/runner/work/EnergyPlus/EnergyPlus/src/EnergyPlus/AirflowNetwork/src/Solver.cpp:48:" & @CRLF & _
"In static member function ‘static _Up* std::__copy_move<_IsMove, true, std::random_access_iterator_tag>::__copy_m(_Tp*, _Tp*, _Up*) [with _Tp = char; _Up = char; bool _IsMove = false]’," & @CRLF & _
" inlined from ‘_OI std::__copy_move_a2(_II, _II, _OI) [with bool _IsMove = false; _II = char*; _OI = char*]’ at /usr/include/c++/13/bits/stl_algobase.h:506:30," & @CRLF & _
" inlined from ‘_OI std::__copy_move_a1(_II, _II, _OI) [with bool _IsMove = false; _II = char*; _OI = char*]’ at /usr/include/c++/13/bits/stl_algobase.h:533:42," & @CRLF & _
" inlined from ‘_OI std::__copy_move_a(_II, _II, _OI) [with bool _IsMove = false; _II = char*; _OI = char*]’ at /usr/include/c++/13/bits/stl_algobase.h:540:31," & @CRLF & _
" inlined from ‘_OI std::copy(_II, _II, _OI) [with _II = char*; _OI = char*]’ at /usr/include/c++/13/bits/stl_algobase.h:633:7," & @CRLF & _
" inlined from ‘static _ForwardIterator std::__uninitialized_copy<true>::__uninit_copy(_InputIterator, _InputIterator, _ForwardIterator) [with _InputIterator = char*; _ForwardIterator = char*]’ at /usr/include/c++/13/bits/stl_uninitialized.h:147:27," & @CRLF & _
" inlined from ‘_ForwardIterator std::uninitialized_copy(_InputIterator, _InputIterator, _ForwardIterator) [with _InputIterator = char*; _ForwardIterator = char*]’ at /usr/include/c++/13/bits/stl_uninitialized.h:185:15," & @CRLF & _
" inlined from ‘void fmt::v8::basic_memory_buffer<T, SIZE, Allocator>::grow(size_t) [with T = char; long unsigned int SIZE = 500; Allocator = std::allocator<char>]’ at /home/runner/work/EnergyPlus/EnergyPlus/third_party/fmt-8.0.1/include/fmt/format.h:754:26," & @CRLF & _
" inlined from ‘void fmt::v8::detail::buffer<T>::try_reserve(size_t) [with T = char]’ at /home/runner/work/EnergyPlus/EnergyPlus/third_party/fmt-8.0.1/include/fmt/core.h:842:39," & @CRLF & _
" inlined from ‘void fmt::v8::detail::buffer<T>::push_back(const T&) [with T = char]’ at /home/runner/work/EnergyPlus/EnergyPlus/third_party/fmt-8.0.1/include/fmt/core.h:846:16," & @CRLF & _
" inlined from ‘std::string_view fmt::v8::formatter<{anonymous}::DoubleWrapper>::spec_builder()’ at /home/runner/work/EnergyPlus/EnergyPlus/src/EnergyPlus/IOFiles.hh:144:25:" & @CRLF & _
"/usr/include/c++/13/bits/stl_algobase.h:437:30: warning: ‘void* __builtin_memmove(void*, const void*, long unsigned int)’ writing between 2 and 9223372036854775807 bytes into a region of size 1 overflows the destination [-Wstringop-overflow=]" & @CRLF & _
" 437 | __builtin_memmove(__result, __first, sizeof(_Tp) * _Num);" & @CRLF & _
" | ~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~" & @CRLF & _
"In file included from /usr/include/x86_64-linux-gnu/c++/13/bits/c++allocator.h:33," & @CRLF & _
" from /usr/include/c++/13/bits/allocator.h:46," & @CRLF & _
" from /usr/include/c++/13/bits/alloc_traits.h:39," & @CRLF & _
" from /usr/include/c++/13/ext/alloc_traits.h:34," & @CRLF & _
" from /usr/include/c++/13/bits/hashtable_policy.h:39:" & @CRLF & _
"In member function ‘_Tp* std::__new_allocator<_Tp>::allocate(size_type, const void*) [with _Tp = char]’," & @CRLF & _
" inlined from ‘static _Tp* std::allocator_traits<std::allocator<_Tp1> >::allocate(allocator_type&, size_type) [with _Tp = char]’ at /usr/include/c++/13/bits/alloc_traits.h:482:28," & @CRLF & _
" inlined from ‘void fmt::v8::basic_memory_buffer<T, SIZE, Allocator>::grow(size_t) [with T = char; long unsigned int SIZE = 500; Allocator = std::allocator<char>]’ at /home/runner/work/EnergyPlus/EnergyPlus/third_party/fmt-8.0.1/include/fmt/format.h:752:49," & @CRLF & _
" inlined from ‘void fmt::v8::detail::buffer<T>::try_reserve(size_t) [with T = char]’ at /home/runner/work/EnergyPlus/EnergyPlus/third_party/fmt-8.0.1/include/fmt/core.h:842:39," & @CRLF & _
" inlined from ‘void fmt::v8::detail::buffer<T>::push_back(const T&) [with T = char]’ at /home/runner/work/EnergyPlus/EnergyPlus/third_party/fmt-8.0.1/include/fmt/core.h:846:16," & @CRLF & _
" inlined from ‘std::string_view fmt::v8::formatter<{anonymous}::DoubleWrapper>::spec_builder()’ at /home/runner/work/EnergyPlus/EnergyPlus/src/EnergyPlus/IOFiles.hh:144:25:" & @CRLF & _
"/usr/include/c++/13/bits/new_allocator.h:151:55: note: destination object of size 1 allocated by ‘operator new’" & @CRLF & _
" 151 | return static_cast<_Tp*>(_GLIBCXX_OPERATOR_NEW(__n * sizeof(_Tp)));" & @CRLF & _
" | ^" & @CRLF & _
"[ 39%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/IGUSolidLayer.cpp.o" & @CRLF & _
"[ 39%] Building CXX object src/EnergyPlus/AirflowNetwork/CMakeFiles/airflownetworklib.dir/src/Elements.cpp.o" & @CRLF & _
"[ 39%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/IGUVentilatedGapLayer.cpp.o" & @CRLF & _
"[ 39%] Building CXX object third_party/libtk205/src/CMakeFiles/libtk205.dir/rs0003.cpp.o" & @CRLF & _
"[ 39%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/IndoorEnvironment.cpp.o" & @CRLF & _
"[ 39%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/LayerInterfaces.cpp.o" & @CRLF & _
"[ 39%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/Layers.cpp.o" & @CRLF & _
"[ 39%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/NonLinearSolver.cpp.o" & @CRLF & _
"[ 39%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/NusseltNumber.cpp.o" & @CRLF & _
"[ 39%] Building CXX object third_party/libtk205/src/CMakeFiles/libtk205.dir/rs0003_factory.cpp.o" & @CRLF & _
"[ 40%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/OutdoorEnvironment.cpp.o" & @CRLF & _
"[ 40%] Building CXX object src/EnergyPlus/CMakeFiles/energyplusparser.dir/DataStringGlobals.cc.o" & @CRLF & _
"[ 40%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/PermeabilityFactor.cpp.o" & @CRLF & _
"[ 40%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/SimpleIGU.cpp.o" & @CRLF & _
"[ 40%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/SingleSystem.cpp.o" & @CRLF & _
"[ 41%] Building CXX object src/EnergyPlus/CMakeFiles/energyplusparser.dir/FileSystem.cc.o" & @CRLF & _
"[ 41%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/SupportPillar.cpp.o" & @CRLF & _
"[ 41%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/Surface.cpp.o" & @CRLF & _
"[ 42%] Building CXX object third_party/Windows-CalcEngine/CMakeFiles/Windows-CalcEngine.dir/src/Tarcog/src/System.cpp.o" & @CRLF & _
"[ 43%] Building CXX object third_party/libtk205/src/CMakeFiles/libtk205.dir/rs0004.cpp.o"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")