re = /^.+?(?=$|\s+\[[^]]*]$)/m
str = 'First string
Second string [Ignore This Part]
Third string (1) [Ignore This Part]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end