re = /(\s|:)(?![^first\sname|last\name]*name)/
str = 'first name:alica last name:foster'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end