$re = '/купи(ть|м|ли|л)/i';
$str = 'Вчера купил наушники
Сегодня купим наушники
Позавчера была дома и потом пошли в молл и купили сноуборд';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);