// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+{0,1}\d{6,}$").unwrap();
let string = "123-456-7890
(123) 456-7890
123 456 7890
123.456.7890
+91 (123) 456-7890
989
787878787
+783788
003883";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}