package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*(\w+)\*`)
var str = `oi pessoas *lindas* e pessoas *lindos*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}